$re = '/^(?!0$)((1\d|2[0-4]|\d)?\d{1,3}|25000)$/m';
$str = '123
0
1
9
10
50000
25001
25000
24999
24001
19999
555
23
20000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);