#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{1,2})? ?([A-Za-z]{3})? ?(\d{4})?$"
Local $sString = "11" & @CRLF & _
"11 Jun" & @CRLF & _
"11 Jun 2025" & @CRLF & _
"2025" & @CRLF & _
"6" & @CRLF & _
"Jun"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")