package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{1,2})? ?([A-Za-z]{3})? ?(\d{4})?$`)
var str = `11
11 Jun
11 Jun 2025
2025
6
Jun`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}