$re = '/^(\d{1,2})? ?([A-Za-z]{3})? ?(\d{4})?$/m';
$str = '11
11 Jun
11 Jun 2025
2025
6
Jun';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);