// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{1,2})? ?([A-Za-z]{3})? ?(\d{4})?$").unwrap();
let string = "11
11 Jun
11 Jun 2025
2025
6
Jun";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}