#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9,]+)\)"
Local $sString = "MINI (0)" & @CRLF & _
"XS (0,5)" & @CRLF & _
"S (1-2)" & @CRLF & _
"L (1 person 1 sprint, 10)" & @CRLF & _
"XL (2 persons 1 sprint, 20)" & @CRLF & _
"TOO LARGE (100)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")