import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9,]+)\\)";
final String string = "MINI (0)\n"
+ "XS (0,5)\n"
+ "S (1-2)\n"
+ "L (1 person 1 sprint, 10)\n"
+ "XL (2 persons 1 sprint, 20)\n"
+ "TOO LARGE (100)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}