import re
regex = re.compile(r"([0-9,]+)\)", flags=re.MULTILINE)
test_str = ("MINI (0)\n"
"XS (0,5)\n"
"S (1-2)\n"
"L (1 person 1 sprint, 10)\n"
"XL (2 persons 1 sprint, 20)\n"
"TOO LARGE (100)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")