using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"0[xX][a-fA-F0-9]{64}";
string input = @"0xf821d3483fc7725ebafaa5a3d12373d49901bdfce1484f219daa7066a30df77d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}