const regex = /0[xX][a-fA-F0-9]{64}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('0[xX][a-fA-F0-9]{64}', 'gm')
const str = `0xf821d3483fc7725ebafaa5a3d12373d49901bdfce1484f219daa7066a30df77d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}