// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)0[xX][a-fA-F0-9]{64}").unwrap();
let string = "0xf821d3483fc7725ebafaa5a3d12373d49901bdfce1484f219daa7066a30df77d";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}