package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)0[xX][a-fA-F0-9]{64}`)
var str = `0xf821d3483fc7725ebafaa5a3d12373d49901bdfce1484f219daa7066a30df77d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}