re = /0[xX][a-fA-F0-9]{64}/m
str = '0xf821d3483fc7725ebafaa5a3d12373d49901bdfce1484f219daa7066a30df77d'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end