$re = '/0[xX][a-fA-F0-9]{64}/m';
$str = '0xf821d3483fc7725ebafaa5a3d12373d49901bdfce1484f219daa7066a30df77d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);