#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\s*)(?<arguments>\([^()\r]*\))(?<body>\s*{((?:[^{}](?!return))*(?:\g<body>)?)+})"
Local $sString = "function test(arg1: test, arg2: test) { " & @CRLF & _
"{{{{{}}}}}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"}"
Local $sSubst = "$1$2: void$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)