$re = '/(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\s*)(?<arguments>\([^()\r]*\))(?<body>\s*{((?:[^{}](?!return))*(?:\g<body>)?)+})/m';
$str = 'function test(arg1: test, arg2: test) {
{{{{{}}}}}
}';
$subst = "$1$2: void$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;