const regex = /(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\s*)(?<arguments>\([^()\r]*\))(?<body>\s*{((?:[^{}](?!return))*(?:\g<body>)?)+})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\\s*)(?<arguments>\\([^()\\r]*\\))(?<body>\\s*{((?:[^{}](?!return))*(?:\\g<body>)?)+})', 'gm')
const str = `function test(arg1: test, arg2: test) {
{{{{{}}}}}
}`;
const subst = `$1$2: void$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);