import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<name>[a-zA-Z0-9]*(?<!constructor)(?<!if)\\s*)(?<arguments>\\([^()\\r]*\\))(?<body>\\s*\\{((?:[^\\{\\}](?!return))*(?:\\g<body>)?)+\\})";
final String string = "function test(arg1: test, arg2: test) { \n"
+ "{{{{{}}}}}\n\n\n"
+ "}";
final String subst = "$1$2: void$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}