#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xm)^" & @CRLF & _
"(?=[^a-z\n]*[a-z]) # ensure one lower case letter" & @CRLF & _
"(?=[^A-Z\n]*[A-Z]) # ensure one upper case letter" & @CRLF & _
"(?=[^\d\n]*\d) # ensure a digit" & @CRLF & _
"(?=[^!@?\n]*[!@?]) # special chars" & @CRLF & _
".{10,} # at least 10 characters long" & @CRLF & _
"$"
Local $sString = "1234567890" & @CRLF & _
"AAAAAAAAAA" & @CRLF & _
"ABCDEFG123@a" & @CRLF & _
"aaaaa" & @CRLF & _
"@@@@@" & @CRLF & _
"abdgdgdh45FG@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")