$re = '~^
(?=[^a-z\n]*[a-z]) # ensure one lower case letter
(?=[^A-Z\n]*[A-Z]) # ensure one upper case letter
(?=[^\d\n]*\d) # ensure a digit
(?=[^!@?\n]*[!@?]) # special chars
.{10,} # at least 10 characters long
$~xm';
$str = '1234567890
AAAAAAAAAA
ABCDEFG123@a
aaaaa
@@@@@
abdgdgdh45FG@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);