re = /^
(?=[^a-z\n]*[a-z]) # ensure one lower case letter
(?=[^A-Z\n]*[A-Z]) # ensure one upper case letter
(?=[^\d\n]*\d) # ensure a digit
(?=[^!@?\n]*[!@?]) # special chars
.{10,} # at least 10 characters long
$/xm
str = '1234567890
AAAAAAAAAA
ABCDEFG123@a
aaaaa
@@@@@
abdgdgdh45FG@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end