import Foundation
let pattern = ##"""
^
(?=[^a-z\n]*[a-z]) # ensure one lower case letter
(?=[^A-Z\n]*[A-Z]) # ensure one upper case letter
(?=[^\d\n]*\d) # ensure a digit
(?=[^!@?\n]*[!@?]) # special chars
.{10,} # at least 10 characters long
$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
1234567890
AAAAAAAAAA
ABCDEFG123@a
aaaaa
@@@@@
abdgdgdh45FG@
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)