import re
regex = re.compile(r"""
^
(?=[^a-z\n]*[a-z]) # ensure one lower case letter
(?=[^A-Z\n]*[A-Z]) # ensure one upper case letter
(?=[^\d\n]*\d) # ensure a digit
(?=[^!@?\n]*[!@?]) # special chars
.{10,} # at least 10 characters long
$
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("1234567890\n"
"AAAAAAAAAA\n"
"ABCDEFG123@a\n"
"aaaaa\n"
"@@@@@\n"
"abdgdgdh45FG@")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")