#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)sources ID (\d+)(/(\d+)?/(\d+)?)?"
Local $sString = "1) sources ID 1437/1441/1443" & @CRLF & _
"2) sources ID 150" & @CRLF & _
"3) sources ID 153" & @CRLF & _
"4) sources ID 120/122"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")