use strict;
my $str = '1) sources ID 1437/1441/1443
2) sources ID 150
3) sources ID 153
4) sources ID 120/122';
my $regex = qr`sources ID (\d+)(/(\d+)?/(\d+)?)?`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}