// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)sources ID (\d+)(/(\d+)?/(\d+)?)?").unwrap();
let string = "1) sources ID 1437/1441/1443
2) sources ID 150
3) sources ID 153
4) sources ID 120/122";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}