package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)sources ID (\d+)(/(\d+)?/(\d+)?)?`)
var str = `1) sources ID 1437/1441/1443
2) sources ID 150
3) sources ID 153
4) sources ID 120/122`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}