re = /sources ID (\d+)(\/(\d+)?\/(\d+)?)?/m
str = '1) sources ID 1437/1441/1443
2) sources ID 150
3) sources ID 153
4) sources ID 120/122'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end