using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"sources ID (\d+)(/(\d+)?/(\d+)?)?";
string input = @"1) sources ID 1437/1441/1443
2) sources ID 150
3) sources ID 153
4) sources ID 120/122";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}