package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(К?[0-9\s]+).*?Ламінат\s([\w\s()\/.]+|Х Galaxy 4V)\s([\p{L}\s.']+)`)
var str = `4590 Ламінат Fiori Aqua Zero Дуб Iris фаска (1,67 м2)/5 шт
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}