const regex = /^(К?[0-9\s]+).*?Ламінат\s([\w\s()\/.]+|Х Galaxy 4V)\s([\p{L}\s.']+)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(К?[0-9\\s]+).*?Ламінат\\s([\\w\\s()\\\/.]+|Х Galaxy 4V)\\s([\\p{L}\\s.\']+)', 'gmu')
const str = `4590 Ламінат Fiori Aqua Zero Дуб Iris фаска (1,67 м2)/5 шт
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}