$re = '/^(К?[0-9\s]+).*?Ламінат\s([\w\s()\/.]+|Х Galaxy 4V)\s([\p{L}\s.\']+)/mu';
$str = '4590 Ламінат Fiori Aqua Zero Дуб Iris фаска (1,67 м2)/5 шт
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);