re = /^(К?[0-9\s]+).*?Ламінат\s([\w\s()\/.]+|Х Galaxy 4V)\s([\p{L}\s.']+)/m
str = '4590 Ламінат Fiori Aqua Zero Дуб Iris фаска (1,67 м2)/5 шт
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end