import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(К?[0-9\\s]+).*?Ламінат\\s([\\w\\s()\\/.]+|Х Galaxy 4V)\\s([\\p{L}\\s.']+)";
final String string = "4590 Ламінат Fiori Aqua Zero Дуб Iris фаска (1,67 м2)/5 шт\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}