#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SECONDNAME[1-3]_"
Local $sString = "FILENAME_SECONDNAME1_DS.txt" & @CRLF & _
"FILENAME_SECONDNAME3_DS.txt" & @CRLF & _
"FILENAME_SECONDNAME8_DS.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")