use strict;
my $str = 'FILENAME_SECONDNAME1_DS.txt
FILENAME_SECONDNAME3_DS.txt
FILENAME_SECONDNAME8_DS.txt';
my $regex = qr/SECONDNAME[1-3]_/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}