$re = '/SECONDNAME[1-3]_/';
$str = 'FILENAME_SECONDNAME1_DS.txt
FILENAME_SECONDNAME3_DS.txt
FILENAME_SECONDNAME8_DS.txt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);