// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"SECONDNAME[1-3]_").unwrap();
let string = "FILENAME_SECONDNAME1_DS.txt
FILENAME_SECONDNAME3_DS.txt
FILENAME_SECONDNAME8_DS.txt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}