using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SECONDNAME[1-3]_";
string input = @"FILENAME_SECONDNAME1_DS.txt
FILENAME_SECONDNAME3_DS.txt
FILENAME_SECONDNAME8_DS.txt";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}