package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SECONDNAME[1-3]_`)
var str = `FILENAME_SECONDNAME1_DS.txt
FILENAME_SECONDNAME3_DS.txt
FILENAME_SECONDNAME8_DS.txt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}