#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\d*(min-width|max-width):\s*(\d+\s?)(px)"
Local $sString = "all and (min-width: 640px) and (max-width: 1023px)" & @CRLF & _
"min-width:640px" & @CRLF & _
"@media screen and (max-width: 699px) and (min-width: 520px)" & @CRLF & _
"media screen and (min-width: 1001px)" & @CRLF & _
"@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")