package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d*(min-width|max-width):\s*(\d+\s?)(px)`)
var str = `all and (min-width: 640px) and (max-width: 1023px)
min-width:640px
@media screen and (max-width: 699px) and (min-width: 520px)
media screen and (min-width: 1001px)
@media screen and (max-width: 699px) and (min-width: 520px), (min-width: 1151px)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}