# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^---)((?:(?!^---)[\s\S])+?^date:\s*)(.+)((?:(?!^---)[\s\S])+?)(^---)/$1$2substitution$4$5/gm;t' <<< "---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---"