const regex = /(^---)((?:(?!^---)[\s\S])+?^date:\s*)(.+)((?:(?!^---)[\s\S])+?)(^---)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^---)((?:(?!^---)[\\s\\S])+?^date:\\s*)(.+)((?:(?!^---)[\\s\\S])+?)(^---)', 'gm')
const str = `---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---`;
const subst = `$1$2substitution$4$5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);