import re
regex = re.compile(r"(^---)((?:(?!^---)[\s\S])+?^date:\s*)(.+)((?:(?!^---)[\s\S])+?)(^---)", flags=re.MULTILINE)
test_str = ("---\n"
"title: test\n"
"date: 2018/10/17\n"
"description: some thing\n"
"---\n\n\n"
"lorem ipsum\n"
"date: 2018/10/18\n"
"lorem ipsum\n\n"
"---\n"
"title: test\n"
"date: 2018/10/17\n"
"description: some thing\n"
"---\n\n"
"---\n"
"title: test\n"
"nodatehere:\n"
"description: some thing\n"
"---")
subst = "$1$2substitution$4$5"
result = regex.sub(subst, test_str)
if result:
print(result)