#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^---)((?:(?!^---)[\s\S])+?^date:\s*)(.+)((?:(?!^---)[\s\S])+?)(^---)"
Local $sString = "---" & @CRLF & _
"title: test" & @CRLF & _
"date: 2018/10/17" & @CRLF & _
"description: some thing" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"lorem ipsum" & @CRLF & _
"date: 2018/10/18" & @CRLF & _
"lorem ipsum" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"title: test" & @CRLF & _
"date: 2018/10/17" & @CRLF & _
"description: some thing" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"title: test" & @CRLF & _
"nodatehere:" & @CRLF & _
"description: some thing" & @CRLF & _
"---"
Local $sSubst = "$1$2substitution$4$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)