$re = '/(^---)((?:(?!^---)[\s\S])+?^date:\s*)(.+)((?:(?!^---)[\s\S])+?)(^---)/m';
$str = '---
title: test
date: 2018/10/17
description: some thing
---
lorem ipsum
date: 2018/10/18
lorem ipsum
---
title: test
date: 2018/10/17
description: some thing
---
---
title: test
nodatehere:
description: some thing
---';
$subst = "$1$2substitution$4$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;