#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\/\*[\s\S]*?(.*?)\*\/)|(\/\/.*)"
Local $sString = "/*" & @CRLF & _
" function to do things with" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"function myFunction() {" & @CRLF & _
" this.x=55; //Some value" & @CRLF & _
" //start the function" & @CRLF & _
" this.start();" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")