// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\/\*[\s\S]*?(.*?)\*\/)|(\/\/.*)").unwrap();
let string = "/*
function to do things with
*/
function myFunction() {
this.x=55; //Some value
//start the function
this.start();
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}