$re = '/(\/\*[\s\S]*?(.*?)\*\/)|(\/\/.*)/m';
$str = '/*
function to do things with
*/
function myFunction() {
this.x=55; //Some value
//start the function
this.start();
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);